I just upgraded to 6.0 and it works out of the gate. On the Bitbucket server itself, the app loads and all of my data is there, working off of the same port. My previous installation had a Windows Service created and would allow me to log out of the server, restart etc and BitBucket would just work 7990.
Now, after installation, the service is stopped and the window that states "Separate 'Tomcat' window" Please note that if you close this window, you will shut down BitBucket.
I've read the articles on how to change the path of the executable for the Windows Service to point at the new installation.
When I start it, I get a fatal error saying the previous version, home directory is incompatible. Any ideas or steps I should take?! I'm at a loss.