We are running a trial of Jira and Confluence, and inserting a link to a Jira issue in a Confluence page. We have recently changed the Base URL in Confluence from localhost:8090 to servername:8090.
If Remote API is disabled in Confluence options, then the link URL in Jira refers to the correct base, but the link text is "Failed to load Wiki page".
If Remote API is enabled, then the link text displays the page title correctly, but the link base url is localhost:8090.
Is there an old config setting somewhere that is being referenced only when the Remote API is enabled?
Martin