Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why can't I log in?

For the past two days, whenever I try logging in to Trello, the page just doesn't load.

I tried creating a new browser profile, with identical settings and add-ons installed, and it works on the test profile, but not on my regular profile. (This includes when I clear my cache and cookies.)

Does anyone know why? Have there been reports of things not working over the past two days?

(By the way, it's annoying that you can't copy and paste text in this forum! I had already written this question and had to re-type it because pasting isn't allowed)

I'm using Firefox 79 on Win7 x64.

2 answers

1 accepted

0 votes
Answer accepted

OK, after a LOT of testing, I finally found the answer.

In Firefox, I have this privacy setting enabled:

network.http.referer.spoofsource

This setting stops Trello from working!

I'm going to report this as a bug, but until they fix it I either have to not use Trello, or disable this setting when I want to log in!

I'm not sure if it's the same problem or not, but I have had problems with Trello not loading after I have logged in. So, logging in technically works, but actually using Trello is not really possible because the page does not load.

I have traced this problem to the service worker that trello.com registers on first load. During subsequent loads, the following errors are displayed in console:

Screenshot_20200813_225438.png

Using private window helps because the service worker will not be used. According to technical documentation about service workers: ”In Firefox, Service Worker APIs are also hidden and cannot be used when the user is in private browsing mode.” (Source: https://developer.mozilla.org/en-US/docs/Web/API/Service_Worker_API)

It would be great to have a real solution to this and not need to work around with private browsing or disabling service workers completely.

Tested with Firefox 79 and Firefox 81.0a1 (2020-08-13) on Arch Linux.

(By the way, copying and pasting here works for me.)

Lliehu, THANK YOU!

You really have identified the problem here! As you said, I can log in, it's just loading the page that's the issue. Sometimes I could see my board, but when I click on the cards it would stop responding.

I've just tried your suggestion of using a Private Window, and it works!

I don't really understand the technicalities of what's going on here, but I would like to report this/send feedback to Trello. Can you tell me what I should say to them?

Thanks again :-)

I don't have anything new to add to my answer, so I think forwarding that would be good, plus what you think are relevant bits of our conversation.

Like Lee likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: Your favorite Trello blog takeaway

Hello friends! From the community that brought you Welcome Wednesday, Throwback Thursday and Friday Fun, welcome to Taco Tuesday, a weekly discussion about all things Trello. The best part? One Tac...

229 views 11 10
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you