Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,301,205
Community Members
 
Community Events
165
Community Groups

Accessing draw io diagram within trello.com - invalid return_url at authorization

Edited

Hi again

Don't know if this is just a temporary thing but I am getting the following error after clicking on the "authorize" button after attempting to "Edit" a draw io power-up diagram (saved as XML) from a card within trello.com online.

Invalid return_url. Wildcard ("*") allowed origins are no longer supported. Contact the developer. See https://community.developer.atlassian.com/t/52093

authorize URL was:

https://trello.com/1/authorize?response_type=token&key=<removed>&return_url=https%3A%2F%2Fwww.draw.io&callback_method=postMessage&scope=read%2Cwrite&expiration=never&name=draw.io

 

3 answers

1 accepted

0 votes
Answer accepted

Hi Paul, please contact support for that Power-Up. To find the support email, go to the Power-Up's listing at `trello.com/power-ups` and look on the left side bar.

When you contact them, please tell them exactly what you showed us here (or just like them to this post!).

Thanks,

Jireh

I think Atlassian need to investigate this. It worked fine until today and without us having made any config changes it suddenly pops up. It's not using a legacy app key.

OK, I thought the dev post was from September 2016, not September 16th...

Thanks , since this morning after clearing my browser cache it is now working again

Invalid return_url. The return URL should match the application's allowed origins. Contact the developer.

We are the developers, and we sent return_url now and we're sure that it does match the allowed origins. 

Where we can find updated documentation if the one you mentioned is 2 years old?

Thanks!

Jireh Atlassian Team Nov 17, 2021

The documentation is still correct. If there's anything there that can be clarified, I'm happy to take feedback.

If you're having trouble matching your return_url with your allowedOrigins, please send us a ticket at https://go.trello.com/dev-support, ask for me and I can help you personally.

Does it work now?

Hi David, Sorry unfortunately still no dice today. It was working fine last week up until yesterday so no idea what has changed. I tried on two machines each using latest Edge (chromium version) and also tried on firefox - same issue.

before clicking on the Authorize button there are errors in Browser console - not sure if it is related.

WebSocket connection to 'wss://trello.com/1/Session/socket?clientVersion=build-9170' failed: Error in connection establishment: net::ERR_NAME_NOT_RESOLVED
connect @ socket.ts:218
api-gateway.trello.com/gateway/api/gasv3/api/v1/batch:1

Failed to load resource: net::ERR_NAME_NOT_RESOLVED
api-gateway.trello.com/gateway/api/gasv3/api/v1/batch:1

Failed to load resource: net::ERR_NAME_NOT_RESOLVED

the authorize link is 

https://trello.com/1/authorize?response_type=token&key=--removed--&return_url=https%3A%2F%2Fwww.draw.io&callback_method=postMessage&scope=read%2Cwrite&expiration=never&name=draw.io

there are no errors in the new window browser console within the authorize dialog.

I am using Microsoft exchange to sign in- not sure if this is relevant

I am also using trial of trello premium, not sure if relevant

Jireh Atlassian Team Nov 17, 2021

David, if you're still having trouble, please send us a ticket at our developer help portal: https://go.trello.com/dev-support

Ask for me and I'll help you out personally.

Like David Benson _draw_io_ likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: New years' resolutions with Trello

Congratulations to @Laura Holton , our latest winner of Taco Tuesday! And thanks to @Kristján Geir Mathiesen for sharing the picture of Taco having fun with his new friend  B...

2,408 views 28 42
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you