Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,361,143
Community Members
 
Community Events
168
Community Groups

Suddenly cannot push or access repo from Remote button

Edited

I am logged into bitbucket with Google and up until now sourcetree has used bitbucket on that basis.

If I do a push from sourcetree or from the commandline it simply works, no login required and the remote button takes you to the remote repo.

However just recently the remote button has an exclamation mark and if you click it you just get a continuous spinny in the bitbucket page.  Although the exact same url can be visited directly in bitbucket on the basis of my google account login.  Also if I try to push at commandline or in sourcetree it asks me for basic bitbucket username and password, which I do not have, I login to bitbucket with google.

I made no changes to bitbucket or sourcetree configuration in any way before this happened.  I simple had not touched them.  It happened out of the blue.

Other repos also fail on the remote button click in the same way.

I have tried:

1. Restart source tree.

2. logout of and back in to bitbucket

3. restart pc

4. refresh token on account in sourcetree.

 

All to no avail.  If you can help in anyway I would greatly apprecitae it.

 

1 answer

I have this same issue.  It started for me last week.  Following to monitor solution.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

79,101 views 135 29
Read article

Atlassian Community Events