SourceTree hg flow Start New Feature not working

Setting up a repository for hgflow works fine, but nothing happens when I try to start a new feature. Executing a "hg flow feature start featurename" from TortoiseHg Workbench works just fine.

Closing the feature from SourceTree works.

Tested with SourceTree 1.7.0.32509 and 1.8.3.0.

Is this a know issue?

I have uploaded a video to show what happens: http://youtube.com/watch?v=CsBPd6ovmfs

1 answer

1 accepted

I need that solution, but I supposedly don't have permission to view it...

Atlassian wrote:

Are you using System Mercurial? If so, I'm afraid this is a known bug:

The workaround at the moment is to switch to Embedded Mercurial, it should work ok with the embedded version. I also suggest that you add yourself as watcher to the public ticket, as the developers will post any updates there.

Ok, I had recently switched to system Mercurial. Tried to switch back, but didn't seem to help, so I uninstalled SourceTree, deleted the %appdata%/local/Atlassian folder and reinstalled. Then it worked again. (Using v1.6.23. 1.9.x versions were too unstable)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

798 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you