Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,377
Community Members
 
Community Events
176
Community Groups

SourceTree hangs on startup

Whenever I startup SourceTree it just hangs. All I get is a white window with a title bar. After some time it becomes unresponsive. I'm using Windows 10. I've uninstall and reinstalled SourceTree several times, but nothing changes.

This is such a vague problem, that my question is really, how can I start to debug SourceTree so I can at least figure out where to start looking?

5 answers

1 accepted

1 vote
Answer accepted

Turns out I needed to uninstall and then delete the %LOCALAPPDATA%\Atlassian folder. Then, after reinstalling, SourceTree was much happier. So something in that folder was holding it up.

Logfile is at ${LOCALAPPDATA}\Atlassian\SourceTree\sourcetree-details.log , and contains nothing. Hows yours?

I'm having trouble opening Sourcetree after i updated to version 1.6.23, and is also using Win10. But i don't even get a white window. I will try to downgrade.

Thanks for pointing me at the right folder. Just needed to delete it.

0 votes
Dan Puza I'm New Here Dec 15, 2022

Sourcetree started hanging for me at the startup splash screen today.  This was the fix, to delete the Atlassian folder and reinstall.

Dan Puza I'm New Here Dec 15, 2022

Uninstalling alone didn't work without also deleting the folder.  Until deleting it, the install program hanged the same way at the splash screen.

Application freezes when a connection to BitBucket host can not be established.

Same thing happend to my 'Source Tree', hangs every time on startup.  Using the latest release (can't tell which release it is since the app always hangs).  deleted %LOCALAPPDATA%\Atlassian however, the app (after reinstall) still hangs after i re-added my repos.  Turns out deleting %LOCALAPPDATA%\Atlassian will remove all app settings (repos etc).  i will try going back to a really old version (that i know worked) and if that doesn't work i will look for some other tool, this is a bit too disruptive for me. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events