SourceTree does not start after hard shutdown (sudden power off).

My PC (running Win 10 with latest updates) shut down hard from a sudden power off (human error).

I click on the SourceTree icon and it does ... nothing. No message. Just no start. I click on the icon, get the busy symbol for a moment, and nothing.

I did a complete uninstall and install with the latest SourceTree with no change in behavior.


2 answers

1 accepted

0 votes
Accepted answer

I found that the file



was corrupted. Instead of being full of XML, most of the file was full of zeroes (0x00).


I copied the user.config file from the sibling directory. I've lost some settings but SourceTree is working again.


I also tried copying an old user.config but it just kept being corrupted.

Deleting the: 


 directory and reinstalling lost me all the settings but at least it worked!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

982 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you