SourceTree does not start after hard shutdown (sudden power off).

My PC (running Win 10 with latest updates) shut down hard from a sudden power off (human error).

I click on the SourceTree icon and it does ... nothing. No message. Just no start. I click on the icon, get the busy symbol for a moment, and nothing.

I did a complete uninstall and install with the latest SourceTree 1.9.6.1 with no change in behavior.

 

2 answers

1 accepted

I found that the file

 

\Users\<username>AppData\Local\Atlassian\SourceTree.exe_Url_<randomstring>\1.9.6.1\user.config

was corrupted. Instead of being full of XML, most of the file was full of zeroes (0x00).

 

I copied the user.config file from the 1.9.6.0 sibling directory. I've lost some settings but SourceTree is working again.

 

I also tried copying an old user.config but it just kept being corrupted.

Deleting the: 

\Users\<username>AppData\Local\Atlassian

 directory and reinstalling lost me all the settings but at least it worked!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

561 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you