Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,088
Community Members
 
Community Events
168
Community Groups

SourceTree continues to use deprecated Bitbucket APIs

Hello,

 

I get the following error when connecting to my bit bucket repository. Can you please let me know how I can get around this issue?

Regards

Rohit

Login failed for your Bitbucket account.

 

The remote service said: 'The operation couldn’t be completed. (SDNetDomain error 7.)

{

    error =     {

        detail = "This API is no longer supported.\n\nFor information about its removal, please refer to the deprecation notice at: https://developer.atlassian.com/cloud/bitbucket/deprecation-notice-v1-apis/";

        message = "Resource removed";

    };

    type = error;

}'

1 answer

0 votes
bgannin Atlassian Team Jun 28, 2019

Hi @Rohit Sharma,

The latest version of Sourcetree for Mac (3.2.1) does not use any v1 Bitbucket Cloud APIs. Please update and let us know if still encounter any issues.

Brian Ganninger
Principal Developer, Sourcetree

Hello,

Latest version of Sourcetree can't run on macOS 10.12, it requires at least macOS 10.13.

I don't want to upgrade macOS. I can't use Sourcetree no longer.

Like marcello2001 likes this

I get the same problem. Is there a way to solve the problem without updating macOS?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events