Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,212
Community Members
 
Community Events
168
Community Groups

SourceTree can't push after update to version 3.2.6

Edited
Deleted user Sep 03, 2019

I am able to commit through command line and also stage files in SourceTree but can't push it in SourceTree. 

I have reset the password and also updated the URL in the repository path with my latest username and password still not working.

Also, deleted the passwords stored in Credential Manager in Control Panel that starts with git:

But nothing seems to work.

Please help.

7 answers

I faced the same issue, you need to update Git to the latest version and everything will work again 
https://git-scm.com/download/win

Works for me ! Thanks !

This worked for me too.

Worked for me as well!!!

SOLUTION:

1.Uninstall SourceTree.

2.Go to online and download setup file.

3.Reinstall SourceTree and by default, you have 3.1.3 version of SourceTree.

Note: If there is any notifications about update to newest version (3.2.6), just ignore.

HAPPY CODING AND ENJOY YOUR WORK!

Installing 3.1.3 Version worked for me as well. 

Like Henry Gonzalez likes this

Please check if installing .NET 4.8 version solves the crashing issue in Sourcetree 3.2.6. I heard that some users in my organization managed to resolve by updating the .NET version. I haven't tried this myself.

I guess testing is hard to do for Atlassian -_-T

I install sourcetree 3.2.6 on new install win10 (18362.356) desktop.

I can't commit anything, when I chick Commit Button the SourceTree GUI will Crashed

I too am facing issues with 3.2.6 on win 10 and that is too weird.none of my colleague reported that there had been a push which was not at all part of the branch working on. Either source tree version is having issues with pulls or may be it is something else. I had replicated the code but this was too strange. Earlier last month all of sudden the version 3.1.3 started giving trouble, please assist

I had the same problem when updating to version 3.2.5. 

What I did was to uninstall v3.2.5 and then went to https://sourcetreeapp.com/ and downloaded the version available there which is 3.1.3.  That version works fine.

Why the latest version (3.2,6) is not the one being downloaded from the official website is strange. I won't update from within the program, just from the webpage. 

Are you still experiencing this issue? I too have had an issue since I updated yesterday to the latest release. I'm unable to push anything to my repo on bitbucket - it just crashes out.

Uninstalled Sourcetree, re-installed older version, and although it doesn't crash, it fails the push silently.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events