It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree Windows - Update Embedded Git Fails 'Unable to extract'

Windows 7 SourceTree version 1.6.13.0

Tools > Options > Git > Update Embeded Git  Fails with:

PortableGitUnableExtract.png

 

 

5 answers

Still a problem trying to get to 2.18.0. Fixed by opening Task Manager and killing ssh. Installed sweetly after that. Insane error on Atlassian's part, moreso that it's gone on so long.

this worked for me.

Like fifthstreet likes this

Confirmed on 1.6.20 as well: http://i.imgur.com/uC2YC9Q.png

Occurs in version 1.6.25.0 with downloaded PortableGit-2.6.1-32-bit.7z.exe

SourceTree.git.update.download.jpgSourceTree.git.update.failed.jpg

Same here. Windows 8.1 and SourceTree 1.7.0.32509

 

immagineerroresourcetree.jpg

Edit:

 

Solved with method at https://jira.atlassian.com/browse/SRCTREEWIN-2962

still same issue on Sourcetree 2.1.2.5, runnning windows 10.

Killing pageant.exe, ssh-agent.exe, git.exe etc, does not help.

Commented the mentioned issue also.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you