Source Tree 1.9.6.2 failing to install Edited

Hi,

 I had uninstalled source tree 1.8.3 and trying to install 1.9.6.2 but system says the most recent version of source tree is already installed on this computer, also tried to install latest version of source tree, but popup saying "JavaScript load error" shows on click button "use an existing account".

can you please help me resolve this issue?

 

Thanks

2 answers

0 votes

Hi,

Are you using a Mac or PC? 

In many instances when I've uninstalled a program there were files remaining that did not get deleted and you'll need to find those files and remove them.

One specific file that often causes this issue is the preferences file.  There is a knowledge base article titled How to Wipe SourceTree Preferences.  Go through that knowledge base article and delete any folders/files related to SourceTree and retry the install.

Cheers,

Branden

Thanks for the reply!

I am using Windows 7 and i had tried by deleting all relevant folders, still the same issue.

0 votes

 

 

Hi! It could be that the uninstall hasn't cleared all the registry settings. You can go to Control Panel > Programs > Programs and Features and make sure the older SourceTree versions are removed, then reboot your system to make sure the uninstall is complete.

 

If you want to give it another go, you can also try a clean install following the steps:

 

  1. Wipe Sourcetree preferences.
  2. Uninstall Sourcetree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step:
    • Navigate to C:\Users\<UserName>\AppData\Local and delete Sourcetree & Sourcetree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all Sourcetree Files/ folder.
  4. Download SourceTree and install it.

Regarding the error you mentioned when clicking the button "use an existing account", I guess you'll need to fix JavaScript in your Internet Explorer as Sourcetree relies on it for the authentication. You can find the instructions at https://support.microsoft.com/en-us/help/3135465/how-to-enable-javascript-in-windows

If after this you're still having trouble, please send us a screenshot and let us have a look at the logs.

Cheers!

Ana

these all ways I have already tried and didn't get a solution and I am using chrome not IE.

the above-mentioned ways already had tried and didn't get a solution and the screenshot attached above.

Sourcetree uses IE for the authentication, regardless of which browser you normally use so we'll need you to confirm that the settings in Internet Explorer are correct so be can identify if this is causing the issue or not. 

Make sure your IE is updated and follow the steps at How to enable Javascript on Windows to fix JavaScript in your Internet Explorer as Sourcetree relies on it for the authentication. 

If after this it still fails, let us have a look at the logs.

Best regards, 

Ana

thanks for the reply.

made settings changes in IE still not working. I am using IE8, is that causing an issue?

Issue solved.

updated IE8 to IE11.

 

thanks

Glad to hear this issue is now fixed!

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

258 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot