Red Check appears on all classes in Visual Studio after cloning and retrieving Remotes

We have begun using STASH and Source Tree at work with VS 2013.  For some reason, the problem below only affects my computer.  When I clone for the first time, everything has a red checkmark by it in Visual Studio.  For other developers, they have a blue lock icon.  I have worked this around by selecting everything and pressing Undo from the context menu. 

But this becomes an issue when I retrieve all remotes from what others have worked on using Fetch and Pull.  All new work when retrieved into my Visual Studio is checked red.  Undo at this point would remove the changes, which I obviously want to keep.  Not doing undo means I have to commit and so on. 

I should mention that we work on individual classes that are part of a larger solution.  Multiple people do not work on different parts of the same class, if that is of any help. 

Any ideas on why this happens only on my computer and how I can fix it. 

Thanks

 

Tim

1 answer

Forgot to mention, Source Tree version is 1.8.3.0

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

840 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you