Password Required dialog fails

I recently reformatted my Macbook's HD when upgrading to MacOS High Sierra. Since getting it set back up, I have been having problems accessing my Bitbucket repos using SourceTree.

I scoured the community and have tried everything suggested on previous similar issues, but none of them have worked.

My account is set up properly & connected. I am using Oauth for my auth type & https for my protocol. My account is connected.

I can see my repos listed when I click on remote but if I try to clone them, I get a dialog box:

   Password Required
   For user [my account id] on host bitbucket.org

When I enter my account's password, it is rejected. 

Help with this would be immensely appreciated. I am out of ideas here.

1 answer

This widget could not be displayed.

Hi @Andrew Schlossberg,

You shouldn't need to enter the password. Sourcetree should be able to use the OAuth token already stored. I'd recommend you to remove the account once, verify that keychain item for the bitbucket account is removed and add the account back afresh. If you still see issues, please enable debug logging by running following statement in the terminal and send us the logs. 

defaults write com.torusknot.SourceTreeNotMAS logLevel 5

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

885 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you