How do I fix??? Error pushing to remote?

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push -v --tags --set-upstream MemberTree1 refs/heads/HEAD:refs/heads/HEAD 

Pushing to https://Hawkcode@github.com/Hawkcode/MemberTree1.git

error: src refspec refs/heads/HEAD does not match any.

error: failed to push some refs to 'https://Hawkcode@github.com/Hawkcode/MemberTree1.git'

Completed with errors, see above

 

Using Mac High Sierra and Sourcetree 2.6.3 (164)

1 answer

0 votes

 

Hi Richard, have you tried the command line to see if you get the same error? This will help us identify if this is an issue with Sourcetree or with something else.

One of the reasons why you might be receiving this error is because you haven't committed anything to your repo yet. Is this your case? If it is, you can do so by:

git commit -m "initial commit"
git push origin master

This is also documented in this Knowledge base article.

Let us know if this helped!

Best regards,

Ana

This project has hundreds of commits. I really don't know the command line, hence Source Tree.

I must of done something when I did the commit to cause this but I don't know what.

 

Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

831 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you