It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Extra / appearing in pull request URLs

Recently each time I have created a pull request in SourceTree the automatic URL generated for BitBucket has an extra / in it.

bitbucket-error.png

This is leading to 404s. If I remove the extra slash the pull request loads as expected.

What is causing this? I can't seem to find any settings that relate to this.

1 answer

1 accepted

4 votes
Answer accepted
Danyal Iqbal Community Leader Jul 18, 2018

Please check your

  • Repository\Repository Settings
  • Edit the properties or the remote where you want to create pull requests
  • Specify the host type and URL, optionally the user
    • Supports Stash, BitBucket and GitHub

if everything looks ok than +1 for Bug.

Ah interesting! It appears that the remote is set differently in our newer repositories.

st-remote.png

If I reselect BitBucket from the list the automatically populated URL doesn't have the slash. I don't remember changing any settings recently.

I'll get my team to manually check this setting on all their repos.

Thanks for the help!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,935 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you