Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Error with hg flow action: failed to import extension hgext.hgflow

nscherer
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 11, 2018

I am attempting to start a new feature branch with Repository -> Hg Flow -> Start new feature.  I enter the name and click OK, and get this error:

 

hg flow -y feature start GPS
*** failed to import extension hgext.hgflow from C:\Users\Nate\AppData\Local\SourceTree\app-2.6.10\extras\hgext\hgflow\hgflow.py: 'module' object has no attribute 'command'
hg: unknown command 'flow'

 

I'm on version 2.6.10.0, Mercurial 4.7, Windows 7 64 bit.  Hg Flow is the only reason I use SourceTree, so if it's broken I'll be uninstalling...

2 answers

0 votes
minnsey
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 6, 2018

Hi We need to update the version of hg-flow we bundle to support Hg 4.8, it will be in an upcoming release

0 votes
minnsey
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 20, 2018

Hi

Have you recently updated to Hg 4.7 was it working before you upgraded? We currently test against and ship with 4.6 so we will check if there is any issue with the hg-flow extension and v4.7

Chris Donaldson
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 10, 2018

Has this issue been resolved. I am still seeing the issue when using Hg 4.7 and SourceTree 2.6.10.0? The Hg Flow doesn't work properly.

s13sb4
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 6, 2018

Having a similar issue with HG 4.8 and sourcetree 3.0.8

redshed
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 6, 2018

I think I resolved this but I don't remember if it was by installing a newer or older version, or what.  Sorry.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events