Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Credential Authentication Issues - Cannot Push or Pull Edited

I cannot push or pull since Sourcetree updated last week.

  • Paid 10 user plan
  • Mac Sourcetree Current Version
  • All Repos are in Bitbucket


Error on Pull if I am Logged in to bitbucket.com

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch origin

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

fatal: Authentication failed for 'repo.git'

 

Error on pull if I am NOT logged in to bitbucket.com

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch origin

remote: Too many invalid password attempts. Try logging in through the website with your password.

fatal: unable to access 'repo.git/': The requested URL returned error: 403

Completed with errors, see above

 

If I try to Refresh Remote I get these errors:

Screen Shot 2018-04-03 at 2.32.36 PM.png

bitbucket error.png

 

However, if I check, my account indicates I am using Oauth:

Screen Shot 2018-04-03 at 2.25.47 PM.png

 

I tried re-saving my username as was suggested elsewhere as well as clearing cache and using both Chrome and Safari.

I am reluctant to change my username as is suggested as it would change the URL of all of my (dozens) of Repos as far as I understand.

 

 

1 answer

0 votes

Hi! Have you tried performing the same operations from the command line? Are you getting the same errors?

If you're also getting errors when you use the command line, it means there's an issue with the authentication. Otherwise, the issue is between Sourcetree and Bitbucket. If so, 

can you confirm your credentials have been correctly added in Sourcetree? You can do so following the steps at Connect your Bitbucket account.

Regarding your last comment, where does it say to change your username? I've seen changing the password as a recommended method sometimes, but I don't think changing the username has been recommended. 

Best regards!

Ana

 I tried a git pull from the command line and received the response

Not a git repository (or any of the parent directories): .git

The .sourcetreeconfig file shows the correct username

The correct baseurl

This happens with any of my repositories...

I really have to find an answer for this issue. Can you assist?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,266 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you