Clone UI fails to parse URL with "Error: System.ComponentModel.Win32Exception: ..."

Just installed SourceTree 2.3.5.0 on Win7.

When I try to clone, I see a complaint below the URL:

Repository type ? This is not a valid source path / URL

The Details button shows me this:

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false ls-remote https://jarkman@bitbucket.org/bristolmaritimerobotics/whiskers.git
Output:
Error: System.ComponentModel.Win32Exception: The system cannot find the file specified

 Seems like a SourceTree bug, not a problem with the URL to me. Any idea how I can fix it ? 

 

Thanks!

Richard

 

1 answer

0 votes

Hi

Is that the full error message?

I'd be tempted to say it cannot find git, but are other repos working OK?

You can check the git settings in Tools/Options/Git tab

That's the whole message, and (having cloned from the command line) SourceTree can now push & pull happily. That seems to suggest that it can find git for other purposes.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

262 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot