Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot push to GitHub: Device Not Configured

Getting this error trying to push to a GitHub Repo.

Account is configured using OAuth over HTTPS, so the previous answers about ensuring the SSH key is loaded do not apply.

I've tried both 2.7 and 2.6.3a .

I have already tried removing the accounts and re-adding them, but I get the attached dialogs:

dnc.jpg

prompt0.jpg

prompt1.jpg

2 answers

0 votes
Manju Atlassian Team Feb 09, 2018

Can you list all the remotes in repository browser window? This alert is typically shown when the account isn't added or if the config doesn't have the username specified. 

Yes, all my remotes are visible.

Screen Shot 2018-02-09 at 12.05.18 PM.jpg

Manju Atlassian Team Feb 09, 2018

That's very strange. Is there a chance that you can use ssh for the time being while we investigate this issue?

Manju Atlassian Team Feb 09, 2018

Can you use this custom build and provide more logs?

https://drive.google.com/file/d/1qM8VRBtr-m_d0lge8Nfs1RtTtBG62JBo/view?usp=sharing

This would help us identify and resolve the issue.

Thanks!

@Manju

I have collected some additional logs.
Are the logs safe to post here? It appears to contain password/tokens.

Manju Atlassian Team Feb 13, 2018

Awesome! You can send those logs to my email - mbasaralusrinivasa@atlassian.com

Thanks!

@t3rminus @Manju

Were you able to solve this issue?

I'm having the same problem, I've added my account through SSH and HTTPS but it always say "Device not configured".

It started yesterday and since then I can only pull/push to repositories if I put my password on the URL of the remote (in my case Bitbucket)...

The issue was solved by way of a custom build form Manjunath, which contained pre-release fixes that I understand were made into a part of the 2.7.1 release.

In any case, I'm not experiencing the issue any more.

Unfortunately this problem just began for me, I guess I will have to create a new topic about it.

Thanks for letting me know!

Manju Atlassian Team Apr 06, 2018

Let me know if you have added another topic with more details of the error.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,318 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you