Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,709
Community Members
 
Community Events
176
Community Groups

Can't connect to Bitbucket account from Sourcetree "Invalid redirect_uri"

Edited

When I try to connect my (freshly installed, but very old versioned) sourcetree to my bitbucket account, after taking my credentials, it tells me:

"Confirm access to your account
Invalid redirect_uri
This integration is misconfigured. Contact the vendor for assistance."

I am trying to run Sourcetree on an old mac (El Capitan, 10.11.16) and installed Sourcetree version 2.7.6.

2 answers

I found the fix

 

 Screenshot 2020-10-16 110908.png

Took two seconds to get my BitBucket and GitHub connected. It was effortless. 

Yeah this is extremely frustrating and I have no idea how it made it past the most basic QA tests before release. 

It also opens up a million tabs because there is a URL parsing issue in their code. This occurs when you try to use OAuth on 3.3.9 of Sourcetree.

I was once much nicer about it but at this point, it's a sign that they do not care. Thusly it should not be very insulting, perhaps motivating to fix their product. 

Happens in 3.3.8 too. There must be some bad data being passed from their auth server.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events