Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,139
Community Members
 
Community Events
168
Community Groups

Can not get SourceTree to Authenticate BitBucket Account

I know this is oft-asked question, but none of the solutions I can find here (or elsewhere) seem to work.

 

The problem:

 

 - Installed SourceTree on my Macbook Pro.  During the installation process, when I get to the "Connect an Account" section, OAuth/Connect Account button flashes a 'Loading Sign-In page' for a second and disappears.  Happens every time I press it.

 - Changing Authentication to Basic and putting in my username does bring up my SSH Key...but the CONTINUE button is greyed out.  There's nothing else to press or do (except Copy to Clipboard).

 

Screen Shot 2020-09-14 at 8.42.33 PM.png

 - Switching to HTTPS lets me put in a password...but the CONTINUE button is still greyed out.

 - Created a GitHub account to see if that worked, and while it does actually load up a login screen, once I log in it just freezes at the YOU ARE BEING REDIRECTED TO THE AUTHORIZATION APPLICATION.  The PLEASE CLICK HERE button does nothing.

______

 

So that leaves the Skip Setup Button.  Okay, tried that.  Load up SourceTree and if I click +New Repository, and try to create a New Remote Repository, I get a No Accounts Registered box.  Makes sense.  Click Ok.

Takes me to the Accounts Page.  Add new account, Connect Account button doesn't work again.  Basic Auth Type, my username in and SSH (and generating a key) does nothing.  Switch to HTTPS and I input my password, hit OK, and it creates an account.  (I tried inputting the wrong password and a made up username and it still creates an account).

Back to New Remote Repository and I get: LOADING OWNERS FAILED: AN ERROR OCCURRED WHILE TRYING TO LOAD OWNERS FOR YOUR ACCOUNT.  YOU CAN VIEW THE SERVER'S RESPONSE BELOW.

Error Contents: The operation couldn't be completed. (NSURLErrorDomain error - 1200.) 

 

___

 

Any help or suggestions would be great appreciated.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,795 views 134 29
Read article

Atlassian Community Events