It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Authentication issue accessing GitHub repos

Hello, I'm running SourceTree 2.4 on Mac and after entering the correct credentials for my GitHub account I'm getting the following error: 

Could not authorize request with the available token. Please re-authenticate.

I click the "Sign in" button and the loop continues. Please help!

19 answers

Same experience after upgrading to SourceTree 2.4 (Mac 10.11.6). It happens with any remote repo. Git on the command line is also asking me to reauthorize. git is able to authenticate and recall the authentication. SourceTree is unable to authenticate even after git authenticates.

 

Same here with version 2,4 (Mac 10.12.1)...

Also having this problem since upgrading to 2.4 (Mac 10.12.2)

0 votes
Deleted user Feb 05, 2017

me too!! same problem... delete cache also error 

me too!!!! I Have headache to this problem.... 

Disturbing silence on this topic. 

Same here. Impossible to connect source tree to GitHub. You seem to have a problem with this version!!!! Disturbing silence indeed.

 

Same here, any update to this problem yet? Tried deleting, keys, caches etc to no avail....

I think the problem is in one of the git credential binaries included with sourcetree. I switched to using an external git binary and I haven't had an issue since. I did have to re-login initially.

 

Having the same annoying problem. The silence is deafening.

I guess I'll start using Tower or something...

Same here,

I'm using SourceTree For Mac 2.5c

Mac Os 10.12.4

Github Account have F2A Security

I am experiencing the same problem, has anyone solved it or have work-around solution?

same here, surely someone has figured it out by now?

 

Same here.

I am using MacOS 10.12.4

SourceTree version 2.5.1 (105)

Tried to connect with HTTPS and SSH  but no luck.

My github and bitbucket accounts were the same. Changing my bitbucket account name fixed the issue for me. 

While admittedly annoying, at least things work now and I'm no longer being bestered to supply my password for each character I type.

Having same issue.

I uninstalled SourceTree 2.4 and installed the older version 2.1.5.

Now the cloning is working without the Authentication errors :-)

2019 feb 11 still didn't fix it.

good company good product

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,927 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you