perforce trigger implementation failing

i have introduced a trigger to my perforce testing server in order to have each commit replicated on fisheye. The trigger seems doing nothing but it's not failing. No logs exist anywhere to understand if anything is wrongly written:

My trigger:

Fisheyetrigger change-commit //depot/... "/usr/local/bin/curl -s -o /dev/null -X POST -H X-Api-Key:MY_API_KEY -m 20 http://host:port/rest-service-fecru/admin/repositories-v1/Perforce-Zeke/scan"

where the key was provided by the admins and the host and port are replaced correctly.

Am i doing anything wrong?

1 answer

This widget could not be displayed.

Is it actually getting run by Perforce server? What happens when you run it manually (without -o /dev/null)?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 7 hours ago in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

17 views 0 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you