NPE with jira eclipse connection

Anyone else have this problem with the eclipse JIRA connector?

 

!ENTRY org.eclipse.mylyn.tasks.core 4 0 2015-03-25 14:15:57.197

!MESSAGE Synchronization failed

!STACK 0

java.lang.NullPointerException

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestConverter.isVersionMissingInProjectCache(JiraRestConverter.java:324)

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestConverter.convertIssue(JiraRestConverter.java:269)

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter$5.call(JiraRestClientAdapter.java:324)

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter$5.call(JiraRestClientAdapter.java:1)

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.call(JiraRestClientAdapter.java:744)

    at com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.getIssues(JiraRestClientAdapter.java:314)

    at com.atlassian.connector.eclipse.internal.jira.core.service.JiraClient.findIssues(JiraClient.java:368)

    at com.atlassian.connector.eclipse.internal.jira.core.service.JiraClient.findIssues(JiraClient.java:360)

    at com.atlassian.connector.eclipse.internal.jira.core.service.JiraClient.search(JiraClient.java:755)

    at com.atlassian.connector.eclipse.internal.jira.core.JiraRepositoryConnector.performQuery(JiraRepositoryConnector.java:140)

    at org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeQueriesJob.synchronizeQuery(SynchronizeQueriesJob.java:312)

    at org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeQueriesJob.synchronizeQueries(SynchronizeQueriesJob.java:269)

    at org.eclipse.mylyn.internal.tasks.core.sync.SynchronizeQueriesJob.run(SynchronizeQueriesJob.java:201)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

 

 

1 answer

This widget could not be displayed.

Hi Henry,

I've raised https://ecosystem.atlassian.net/browse/PLE-1582.

What is your Connector version?

UPDATE: I believe you use 3.2.4 snapshot and this bug was introduced when working on the other issue for 3.2.4 (so the stable 3.2.3 is not affected).

I have fixed this NPE so please upgrade and let us know if everything is fine (3.2.4 snapshot have been rebuilt and contains the fix)

Thanks,
Jacek

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

150 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you