I can't push GitHub repojitory

I worked GitHub's Local repogitory using SourceTree.

then I tryed push.

below error is report.

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=manager-st push -v --tags --set-upstream GitHub master:master
Pushing to https://github.com/Beio-Wolf-Com/WHVR.git
To https://github.com/Beio-Wolf-Com/WHVR.git
! [rejected] master -> master (non-fast-forward)


error: failed to push some refs to 'https://github.com/Beio-Wolf-Com/WHVR.git'
hint: Updates were rejected because a pushed branch tip is behind its remote
hint: counterpart. Check out this branch and integrate the remote changes
hint: (e.g. 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

Someone please help me

1 answer

0 votes

Your branch is out of date and needs to pull the latest changes and incorporate them prior to pushing your new changes. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Agile

How Scrum works? It starts with training and education

To answer “How scrum works,” most of the teams I've worked with first addressed the question: “where to start?”  That question applies to both implementation and improvements on the Scrum framew...

168 views 3 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you