Deleting a remote repository isn't working



I'm the owner of a repo and I want to delete it. I navigated towards the "delete repository" via the settings and when I click on "delete repository" and then click again on the button "delete" in the popup window with the red bar nothing is actually happening.

The repository is still there. Tried it also with other repos that are owned only by me.

Not sure what I'm doing wrong here

4 answers

Hi Andreas,

Can you please confirm:

  • Is this happening only for you or also for other users? Can you check?
  • Is this just for personal repositories or also repositories under other projects?
  • Have you tried in another browser?

You may also try debugging this and seeing if you can spot anything from your logs. You can enable debugging at Bitbucket Server Administration > Support > Logging and Profiling, select Enable debug logging and click in Save. After trying to delete your repo you can then check the atlassian-bitbucket.log under your BITBUCKET_HOME/log directory. You may post any output here, or you may also create a support case at in case this needs to be further investigated.


Gustavo Refosco

Thanks Gustavo for trying to help. To answer your questions:


A1) Only for me, no other users on this repo

A2) Personal repo, I don't have a repo under other projects. I work along

A3) You mean in another browser than chrome? No


Given your last question I just tried the same in Safari and it immediately work. So I can confirm it's a chrome browser problem. Actually this isn't the only button that doesn't seem to work in Chrome, also the "share" button on the repo overview page isn't working as well as the "send invitation" button on the same page.


Using Version 46.0.2490.86 (64-bit) of Chrome on a Mac

Site is whitelisted in Ghostery and AdGuard protection is paused, both to no avail

BTW, I couldn't find the debugging, actually I don't even think I'm using the Bitbucket server. I'm just using the "normal" free offer to store my repo's remote

Hi Andreas,

Thanks for checking this. I don't have this specific version of Chrome for testing, but for Chrome Version 47.0.2526.73 (64-bit) on Mac all these buttons worked fine for me - you may give a try upgrading your browser and see how it goes.

Other than that, you may also try to disable any add-on/extension you have and see if this behavior persists.

Regarding Bitbucket, you're actually using Bitbucket Cloud then.


Gustavo Refosco

I can't delete my repository either. I tried with Chrome, Firefox and InternetExplorer. The button does not work.

Other things that do not work: clicking on "" or the two "Command Line" options on "repository setup"


Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

230 views 6 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot