multimedia macro: this plugin is not supported.

Hi all,

I'm learning to use multimedia macro and met difficulties, please help me figure out. Thanks!!

After uploaded the videos as attachment, I inserted the multimedia macro but it doesn't show the video:

For .wmv file and .avi file, it shows: the plug-in is not supported:

image2015-6-26 19:1:55.png

For .mov file and .mp4 file, I installed Quicktime as request but it still shows nothing:

image2015-6-26 19:2:34.png

I also tried smaller file (size: 4mb~16mb) but nothing happened. And neither Chrome nor IE can make them work. 

Does anyone knew what caused this problem? Should I enable any plug-in?

Thanks in advance,

Hongjing FU

2 answers

1 accepted

0 votes
Accepted answer
Stephen Deutsch Community Champion Jun 26, 2015

Hi Hongjing,

I would recommend using a user macro to display HTML5 video (not supported by the multimedia macro, at least not yet).  I have one:

https://bitbucket.org/stephendeutsch/confluence-user-macros/src/39c3a025dacc6b45abc0105f0b7a21a7375690b4/html5video/html5video.vm?at=master

or you could use David Simpson's version (mine is based on his):

https://davidsimpson.me/2013/07/28/html-5-video-user-macro-for-atlassian-confluence/

Both work best with MP4 video.

I have added both of the above two as a macro and tried to play a mp4 video.

 

My video plays only 3-4 minutes out of total 47 minute.

 

 

It provides a VM file content. How to embed this plugin via the Add-Ons Manager?

Stephen Deutsch Community Champion Apr 26, 2016

It is not done via a plugin, but rather the "User Macros" section of the Confluence "General Configuration" options.

Here's some more information: https://confluence.atlassian.com/doc/writing-user-macros-4485.html

Simply choose a name for the user macro (like html5video), copy/paste in the content, and once you save it, it should show up in the macros list.

Thanks a lot Stephen; I've managed to create a new macro. The code provided by David Simpson does not work properly yet, but this is another discussion.

I have the same problem and doesn't succeed to create a working user macro.

How can I modify the code so that it works? Any ideas?

I'm also seeing this issue, after having previously seen these video formats working.

I've added a bug, here: https://jira.atlassian.com/browse/CONF-41623 which I encourage you to vote up and follow. Something's clearly wrong.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,052 views 16 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you