That's not a valid license key.

Hi,

Just bought a starter license to use with my Confluence installation.

Yet, when I copy/paste the license, it says "That's not a valid license key.".

How can I fix that?

Thanks.

3 answers

1 accepted

0 vote

Hello Cédric,

I was able to get in touch with our Advocates team, and I see they had manually provided you with the license. 

Before we proceed, I would recommend first pasting the license key into a text editor that uses plain text, such as Notepad. Then you can copy the license again from that application.

Sometimes a space that is copied is invisible, so you wouldn't see it when copying it yourself. 

Can you give that a try and let us know if you still have any issues? I've had the Advocate verify the license is valid and has valid maintenance, so we just need to narrow down why it might be still failing.

Kind Regards,
Shannon

Hello Shannon,

Thanks for your reply.

I copied/pasted in a text editor (sublime text), then copied/pasted from there to the page and get the same result.

Here are some technical information that might be helpful for diagnosis.

I am using the Confluence docker image (https://hub.docker.com/r/atlassian/confluence-server/), running on a Synology NAS.

I am accessing it through a HTTP reverse proxy.

The NAS has access to the internet (no proxy).

Best,

Cédric

Ann Worley Atlassian Team Aug 01, 2017

Our licenses do not require an Internet connection, as they don't "call home" like some licenses. Your proxy shouldn't be garbling the license.

I applied the license from your support ticket with our customer advocates team and it worked fine on my test instance.

For troubleshooting, please try generating an evaluation license at https://my.atlassian.com and checking whether that will work.

Hi Ann,

Thank you.

The evaluation license also didn't work.

I recreated the container and now it goes through license validation.

I have no idea what went wrong.

Thank you all very much for your time.

Best,

Cédric

Ann Worley Atlassian Team Aug 01, 2017

My pleasure, I wish I could have been of more help. I also wish we knew what happened on that first container but I suppose there are mysteries even in technology.

Thanks for letting us know how you fixed it.

By the way, if anyone gets a nginx gateway timeout during the external database configuration, the reverse proxy is the cause.

I had to disable it.

Ann Worley Atlassian Team Aug 01, 2017

Good to know, thank you!

0 vote

Check that you have copied the whole key, and just the key - no extra spaces or tabs at the beginning or end

I copied the whole key, without spaces nor tabs at beginning and end, and still have the same problem...

I tried on two different browsers (Chrome macOS and Safari macOS)

The key has 77 characters on the first line, 76 on the next 5 lines and 48 characters on the last one.

I tried to see if it was a valid base64 string, which it is not.

I tried to contact Atlassian support but they asked me to ask for support here instead.

I am completely stuck with an invalid license which I cannot use...

Hello , I wonder  how you fixed it ? 

Because I have same issue right now .

Thank you 

Hi,

I basically reinstalled in a new VM if I remember correctly.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

478 views 19 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you