Help for confluence upgrade problem

Hi, in our company a very old version confluence is used now (2.8.1) and the license is expired. What we are planning is to purchase the lisence for the newest version confluence and migrate all the contents from the current old confluence to the new one. I have tried to use the evaluation version to practice the migration process. According to the online documentation, I downloaded and installed the version of 2.8.3 in my computer. After that, I exported one selected space with XML output from the current confluence from server. Then, I imported the exported file into the confluence in my computer. The contents in selected space were displayed properly. Everything worked fine until now. But when I tried to upgrade to 3.5.17 based on the online documentation (just modified the confluence-init.properties file for confluence.home ), the process was failed and the confluence could not start up. I tried the process several times and got the same results every time.

Upgrade failed. Please consult the system logs for details. You will need to fix these problems, restore your database and confluence home directory to the pre upgrade state. Then retry the upgrade.

The log file shows:

2013-07-31 17:00:56,371 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 3.5.17 (build #2176)

2013-07-31 17:01:15,413 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Initialising the plugin system

2013-07-31 17:01:18,553 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] init Plugin system started in 0:00:02.687

2013-07-31 17:01:28,394 WARN [main] [atlassian.config.xml.AbstractDom4jXmlConfigurationPersister] saveDocumentAtomically Unable to move C:\confluence\data\confluence.cfg.xml1313072951404044044tmp to C:\confluence\data\confluence.cfg.xml. Falling back to non-atomic overwrite.

2013-07-31 17:01:28,425 INFO [main] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization started

2013-07-31 17:01:34,470 INFO [main] [com.atlassian.confluence.lifecycle] <init> Loading EhCache cache manager

2013-07-31 17:01:56,152 ERROR [main] [confluence.search.lucene.ConfluenceSearcherInitialisation] initialise Error encountered while warming up searcher - The index has not been upgraded. Please reindex.

2013-07-31 17:02:01,807 INFO [main] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization completed in 33382 ms

2013-07-31 17:02:02,072 ERROR [main] [atlassian.confluence.upgrade.UpgradeLauncherServletContextListener] contextInitialized 1 errors were encountered during upgrade:

2013-07-31 17:02:02,072 ERROR [main] [atlassian.confluence.upgrade.UpgradeLauncherServletContextListener] contextInitialized 1: Thank you for upgrading Confluence. The license format for this new version has changed. In order to complete your upgrade and continue using Confluence, <strong>you will need to upgrade your current Confluence license</strong>. This upgrade does not incur any additional costs and does not change Confluence's functionality in any way.<p>You can upgrade your license <a href="http://my.atlassian.com">here</a> or for step-by-step instructions please refer to our <a href="http://docs.atlassian.com/confluence/docs-35/Confluence+3.0.2+Upgrade+Notes#Confluence3.0.2UpgradeNotes-licenseupgrade">documentation</a>.</p><p>If you cannot upgrade your existing Confluence license, please <a href="https://my.atlassian.com/license/evaluation?product=Confluence&licensefieldname=licenseString&version=3.5.17&build=2176&sid=A4GA-1V9D-HC0H-4IDX&callback={3}&ref=prod">generate a temporary evaluation license</a>. This will allow you to proceed with the upgrade and give you time to generate a compatible license.</p><p>Once you have an upgraded license (or a temporary one), please enter it on this <a href="$CONTEXT/fixonly/fixlicense.action">page</a> and <b>restart</b>.</p>

2013-07-31 17:02:03,244 INFO [main] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve

Could anyone give any suggestion about this problem? Or is there any other way to migrate content between different versions of confluence? OrIs it failed because of the evaluation version? Thanks for your time and patience.

1 answer

1 accepted

According to the error is just complaining about the license, so I suggest you to put this URL <confluence-url>/fixonly/fixlicense.action to repair this problem.

Bernardo

Thanks. Now it works. I'll continue to try to upgrade to 4.3.7 then to the newest version. If all the processes are successful, we will begin the upgrade and migrate task.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 09, 2018 in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

378 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you