It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Excerpt macro in blog post doesn't work properly

Hi,

We're publishing blog posts on our space, and we want to include excerpts of them on our main page.

For each blog post we used the "Excerpt" macro, and then we configured the "Blog Posts" macro on "excerpts", however, we did not have the intended result

post.pngpage.png

 

Is this a bug? Maybe related to CONFSERVER-54223

 

Thanks!

2 answers

I'm having the same problem as Habib, also in a cloud environment.

I have used the Excerpt macro in several blog posts.  But this seems to be ignored by the Blog Posts macro elsewhere in the space.  It includes much more text than is in my Excerpt.

If I use the Include Excerpt macro, the excerpt appears as I would expect.  But I don't want to have to manually update the page each time a blog post is published.

Same here. I did a bug report from this.

Like Ashley_Renlund likes this

I am also having the same problem.

I'm having the same problem here. The "content type: excerpts" option for the blog posts macro ignores the excerpt provided, and also all formatting. 

Hi and welcome to the community!

What is your intended result by the way?

Hi Greg, thank you for your reply.

My intended result would to display what inside the Excerpt macro "This is the test excerpt" in the main page. Currently, the Excerpt macro is ignored, and the "Blog post" macro displays the first few lines of text

Oh, I see.

Have you added the "Excerpt Include" macro to the main page?

excerpt.jpg

No, I used the "Blog post" macro with the excerpt option (as documented in https://confluence.atlassian.com/doc/blog-posts-macro-139470.html)

 

blog post macro.png

I tested the "Excerpt include" macro in the main page, it worked as expected, but we'd rather prefer the display of the "Blog Post" macro (which is supposed to display excerpts).

main page.png

Thank you

Oh, I see now.

Let me reproduce it in my environment and I'll get back to you with the results.

Thank you!!

I've managed to reproduce the issue and it seems ok in my environment:

blogpost.jpg1st blog.jpg

Hmmm, I tried on another page and I still have the same problem. We're using confluence cloud so we should have the last version. What can we do to further analyze the problem?

You said "on another page" but in my example there're 2 different pages (the main one and the blog post itself). I do it the following way:

1. Create a new page and put a blog post macro on it:

1bp.jpg

2. Make sure I choose "excerpts" as Content Type to Display:

2bp.jpg

3. Use the "Create blog post" button to create my first blog post:

3bp.jpg

4. Make a blog post entry with the excerpt in it:

4bp.jpg

And here we go:

resultbp.jpg

 

Is the process the same with you?

Yes, I even redid the exact same steps on my personal space, and I have the same problem.

Is this a bug, or a configuration issue?

Actually, it's hard to tell. We have different environments (I have a server and you - cloud) so there may be something different.

Let's see if anyone else here has any suggestions or reports the same behavior.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

327 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you