CSS stylesheet and background image not displayed anymore

Hi,

I have several pages using CSS style sheets and for around 2 weeks now, I have an issue with background images that are not displayed anymore (whereas this worked for several months)

I've inserted a CSSstylesheet macro and added this:

div.portalpicture {
color:black; 
background-color:#0a71b4; 
background-repeat:no-repeat; 
background-position:50% 50%; 
background-image:url("https://stromasys.atlassian.net/wiki/download/attachments/15794334/website-bg01.png"); 
}

Then later I just insert a div macro using the portalpicture class but I've got only the background color, no more image. Any idea ?

I've already contacted Atlassian Support but they say the problem is related to your macro.

Thanks

Best regards

Bruno

6 answers

1 accepted

When I try it works with or without blank lines in Firefox, IE and Chrome.

So perhaps your problem really has to do with that upgrade!?

Hi, thanks that's the first thing I checked and you can see from the example I gave this image can be read.

I'd say nothing has changed except Atlassian upgraded the Confluence Cloud version. I also just come to create a blank page with that code, added a div macro with portalpicture class and added several blank lines inside the div box and... well.. that works in preview, not after saving and displaying the page smile

Tried with IE11 and Firefox

Hi Steffen,

sorry, couldn't answer yesterday, I haven't enough points to do so (that's illogical... how to resolve an issue with 3 answers max per 24h ?)

I've received more news from Atlassian support and of course, there's another bug introduced with the latest upgrade, see CONF-38578.

Thanks for your help.

Okay, so good luck for a quick bug fix ;-)

Hi,

when I use your code it works. It creates a small strip with the image as background.

If the image does not appear I would first check if the image is still there, if the url is correct and if nothing else has been changed.

Just to be sure:

You are aware that your div with the background image looks like this (correctly!) ?

2015-07-27 15_15_00-Seitenname - Steffen Heller - Lightweb.png

In other words, there isn't much more than a blue background colour. But that is not a fault but just the way the image looks like (when squashed to such a small height!):
https://stromasys.atlassian.net/wiki/download/attachments/15794334/website-bg01.png

 

As I said, add several blank lines inside the div macro, this will display the picture and not only one line.

information I use this div macro in order to adjust the image to the window size and that worked as I expected. This worked for months until that Confluence upgrade 2 weeks ago.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

478 views 19 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you