It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlassian Companion will not run

I am using 6.15.2 and when I try to edit an .xlsx file I am prompted to download the Atlassian Companion. This is what I am doing on both Chrome and Firefox:

0. Click the edit button for the .xlsx file that I want to edit.

1. See the pop-up that tells me about the Atlassian Companion.

2. Download Atlassian Companion .exe and run it.

3. Launch the app via the desktop shortcut (as an administrator).

4. Watch the mouse pointer spin for about 5 seconds.

5. Go back to my attachments page in Confluence and click the 'edit' button for the .xlsx file I used to be able to edit before the invention of the Atlassian Companion.

6. See the pop-up that tells me about the Atlassian Companion.

7. Repeat this endless loop until I am frustrated with the Atlassian Companion (which isn't very long).

1 answer

0 votes

Hey Scott, thanks for sharing with the Community!

As I understand, your Companion App installation is not recognized by the browser or system . I would like to ask you if it would be possible for you to try the *.MSI installer. Here is the link to it:

Administering the Atlassian Companion App | Install the Companion app via Microsoft Installer (MSI)

Could you also clarify a few points to us? Here they are:

  1. Is this working in another machine in your environment?
  2. Has this worked to other users in your organization?
  3. Do you have a firewall or proxy that might intervene with the communication between Confluence and Companion?
  4. Do you have 2FA or a Custom SSO in your environment?

If possible, also try the installation of both *.EXE and *.MSI files in another machine.

Let us know from your Scott!

Thank you Diego for responding. I tried the .msi on 2 machines. My answers are below:

  1. No - I tested the .exe and .msi on 2 machines; same result -> Not Working
  2. No. I asked 2 others to try the .msi without success.
  3. Yes, we have a firewall but I do not know if it would interfere.
  4. Yes, we have custom SSO's.

HTH. Thanks again for responding.

I have the same problem for a few days now. It all worked for years and now it suddenly stopped.

works with chrome but doesn´t work with Firefox ESR 68.3.0 anymore.

All Clients in our Company are affected (Win10, Firefox ESR 68.3.0)

firewallsettings have not been changed

there is no proxy

.msi installer doesn´t cure it

I created a forwardlookupzone for https://atlassian-domain-for-localhost-connections-only.com     pointing at 127.0.0.1 - no effects

Like # people like this

same here - it all worked and a few days ago it suddenly stopped working for a lot of people without us being aware of any system changes.

same here - it stopped working out of the blue for quite some colleagues now. Firefox, IE & Edge - all the same...

same here - was working for 3000 People and now all Windows Clients (Firefox/Chrome/IE) stopped working. All installed via SCCM with msi and nothing in our infrastructure changed.

turns out the problem is a revoked certificate that was somehow compromised, depending on your browser settings regarding certificates this results in the companion app not working becaus of browser security constraints.

Atlassian is working to fix the issue/get a new, valid certificate

Like # people like this

Same problem here. We already updated Companion to 0.7.3 and Confluence to 7.2.0, so the security issue with MITM-attack and regarding the certificate should be fixed.

Chrome 79.0.3945.88 is working nice, but it doesn't work with Firefox 68.3.0esr.

In the console this error message appears after click on "Edit":

Unhandled promise rejection Error: "Failed to connect on any of the ADC ports"

Like R likes this

Are there any Updates for this Problem?

Firefox 60.9.0esr doesn´t work but Chrome 80.0.3987.116 works perfectly.

Upgrade to confluence 7.3.x, the all new companion app doesn't have any problems for us now.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

353 views 11 11
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you