Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Changing username didn't make it available

My question is similar to 1257161. I have two Bitbucket accounts (say, A1 and A2), and since it isn't possible to merge them, I moved all of my repositories to A1. However, in order to be consistent with my other website usernames, I tried to keep the username of A2. I changed A2's username to something else hoping that it would make its previous username available, but it didn't: when I try to change A1's username to the old A2's username, I get an error ("an account with that name already exists"). I waited a few months and nothing has changed. It doesn't even let me change A2's username back to the previous one (which would be good as well, since I would just move my repositories to A2 and keep using it instead). 

Is there something I can do to get my old username back, in any of my accounts?

Thank you.

1 answer

1 accepted

0 votes
Answer accepted
Tyler T Atlassian Team Sep 24, 2020

Are you attempting to change a username or workspace ID?

Here is the username change page: https://bitbucket.org/account/settings/username/change/

Usernames are not important because they are not part of any URL in your Bitbucket project. The workspace ID, however, will show up in the URL.

It seems like you may need to change the workspace ID of A1 to something different, and then change A2.

Hi, @Tyler T,

I'm sorry, I forgot to mention that I tried to change both, and the name I'm trying to use was also a workspace id of the other account. I didn't remember this when I wrote the post yesterday, but I checked a message I had sent to Atlassian support in June (to which I got an answer saying that free accounts should request support on this forum).

If I try to change my username to that old workspace id, it still says that "an account with that name already exists"; however, if I try to change my workspace ID (in any account) to that old value, I get an error page:

"Something went wrong

While we check things on our end, try refreshing the page. If reloading the page doesn’t help, check our status page for known incidents or planned maintenance.

If you are still experiencing issues, our support team can be reached via StatusPage. Use the code below when reporting your issue, this will help the team look up details of what went wrong:

ed7d9a0bbf8d44ab9ac00267f3249dae"

By the way, this is not the same message that is displayed if I try to use a workspace ID that already exists ("this workspace ID is not available"), so there seems to be an inconsistency. 

May I send you the usernames privately? 

Thank you for your support.

Tyler T Atlassian Team Sep 25, 2020

I looked at the error code and it was: This workspace ID is not available.

Not sure why it didn't appear in the UI.

Given the complexity of your situation, it would be best to open a ticket with support about this: https://support.atlassian.com/contact/#/

I've just opened a ticket on there. Thank you.

The issue is now solved. Thank you.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,827 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you