Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

User can't deploy even though permissions are set

I want my qa team members to be able to manually trigger a deployment to their test site.  I have given one of the users deploy permissions to the QA environment.  However when he logs in, he cannot see a deployment action for the environment or any in the plan.

What setting am i missing?

1 answer

0 votes
rsperafico Atlassian Team Nov 14, 2016

Hello Jason,

Created a group called "bamboo-deploy" (any group name would do)

Created a user "deploy" and added to "bamboo-deploy" group

image2016-11-14 15:0:29.png

Create a Deployment / Environment

Granted the following permission

image2016-11-14 15:2:49.png

Logged in to Bamboo with "deploy" user

image2016-11-14 15:3:53.png

As you can see, under Actions the user "deploy" is able to run a deployment

Kind regards,
Rafael P. Sperafico

rsperafico Atlassian Team Nov 14, 2016

Please, make sure the same user/group you are granting deploy permission to the environment has also permission (i.e. view) to the build that will be consumed by this very same environment.

Thanks for your reply.  This sent me in a direction that got me working.....I am using LDAP sync'd users and i was trying to assign deploy permissions directly to the LDAP user and it was not working.  I noticed that in your example above you were using local users/groups.  So i created an internal bamboo group and assigned my LDAP synced user to that group, and then assigned deploy permissions to the local group and it started working great.

rsperafico Atlassian Team Nov 14, 2016

Hello Jason,

image2016-11-14 19:36:17.png

image2016-11-14 19:35:32.png

image2016-11-14 19:33:41.png

"user0" must have view permission to the Project/Plan consumed by the Dpeloyment

image2016-11-14 19:37:9.png

Logged in as "user0"

image2016-11-14 19:37:57.png

Kind regards,
Rafael P. Sperafico

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

912 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you