Some artifacts don't get copied between stages

I have a plan with two stages, with one job in each stage (1: Build, 2:Deploy). The first stage generates four shared artefacts, and the second stage needs to deploy these four artefacts.

Both stages are performed on different machines, so are done by separate agents with appropriate capabilities. The idea is to build them on the first machine, then use the shared artefact dependencies to copy them across to the deployment machine.

When the first stage runs, it finishes successfully, and I can download all four artefacts from the job's 'Artifacts' page. Three of these artefacts are zip files created in subfolders of the job's home directory, and the fourth is an exe created directly in the job's home directory.

The second stage is configured to have all four shared artefacts as dependencies, and their destination directories are all set to be the root of the job's working directory.

When I run the plan, everything finishes successfully, but only the three zip files end up on the deployment machine in the job's working directory. The exe file is nowhere to be found.

According to the logs, all four artefacts are 'prepared' successfully:

simple	08-Aug-2013 14:56:36	Preparing artifact for use: ArtefactOne
command	08-Aug-2013 14:56:36	Substituting variable: ${bamboo.buildNumber} with 30
simple	08-Aug-2013 14:56:37	Artifact ArtefactOne prepared in 0:00:00.516
simple	08-Aug-2013 14:56:37	Preparing artifact for use: ArtefactTwo
simple	08-Aug-2013 14:56:37	Artifact ArtefactTwo prepared in 0:00:00.422
simple	08-Aug-2013 14:56:37	Preparing artifact for use: ArtefactThree
simple	08-Aug-2013 14:56:37	Artifact ArtefactThree prepared in 0:00:00.078
simple	08-Aug-2013 14:56:37	Preparing artifact for use: ArtefactFour
simple	08-Aug-2013 14:56:37	Artifact ArtefactFour prepared in 0:00:00.062
I've obviously changed the names of the artefacts, but 'ArtefactOne' in this case is the exe file, and the other three are zip files. The other difference is that the exe file is the only one whose Copy Pattern is defined with bamboo variables: '*${bamboo.repository.branch.name}.${bamboo.buildNumber}.exe' whereas the other three are simply '*.zip'. The three zip files have their respective locations set, and the exe file has no location as it is created in the root of the working directory.
We are using bamboo version 4.4.3 build 3505
After running the build, the 'build-number.txt' file on the deploy machine is correct in the jobs working directory, but only the three zip files have been copied over, not the exe file.
Can someone please let me know what I can do to fix this?

2 answers

1 accepted

All fixed now - turns out I was missing a '$' sign for one of the variable values.

0 vote

Hi,

Have you tried naming the artifact without using variables to narrow down the problem?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,321 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you