Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,679
Community Members
 
Community Events
176
Community Groups

How can I get bamboo server to detect remote agent custom capabilities?

Our 6.2.3 version bamboo server has a configuration of multiple remote servers.  On one of the remote servers we have added custom capabilities.  However when we go to a build plan and at the custom capability as a requirement of the build plan, bamboo indicates that no agent has the capability.

 

e.g. On remote server we add custom capability name: TestServer value:true

On the build plan we add the TestServer capability with a value of true

And still get an indication that no agent exists with that capability

 

Oddly when we also add the exe path for the tester as a command capability that doesn't work either.  

 

2 answers

0 votes
rsperafico Atlassian Team Mar 08, 2018

Hello @ksondere,

Regarding on your custom and command capability, could you please review if you have dedicated any agent to the PROJECT, PLAN or JOB you have added the Requirement?

For instance, lets say you have two agents (agentA and agentB) and you want to build from PROJ-PLAN-JOB1.

The "agentA" has been dedicated to PROJ-PLAN (it does not matter how it has been dedicated for this example, it could be PROJECT, PLAN or JOB.

The "agentB" is where the custom and/or command capability was added.

By going to PROJ-PLAN-JOB1 and editing Requirements, if you add any capability from "agentB", no agent will be able to build.

Please, review if this is the scenario you are experiencing.

Kind regards,

Rafael

Are you using ui? or bamboo specs?

 

If you added the custom capability on the server it don't need detect any new value.

I've added the custom capability through the UI.

 

I didn't quite understand this statement.  Are you saying that if I add custom capability through the UI that it won't be detected?  So this means I need to add capabilities through the bamboo spec?  Is bamboo spec a properties file?

 

I assume this is a bug that will be fixed?  Is it being worked on?

 

Thanks

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events