Getting "Internal server error" while generating report using "Jmeter Aggregator"

When try to generate reports using the Jmeter Aggregator in Report parameter(in Jmeter plugin UI) the Sampler parameter is empty.We are able to see data in the Metrics parameter. So can you please let us know how can the data get display in the Sampler paramter.Bamboo Error.jpg

2 answers

I have exactly the same issue.

Have you been able to solve the problem?

We think we have a solution. Our plan is called "TST-DEAL" and we have one job, "TST-DEAL-JOB1". From our plan, the URL for the "Load Test Reports" link is:

http://servername:8086/browse/TST-DEAL/aggregate?pluginKey=jmeterAggregator:jmeterAggregatorReports

If we append "&buildKey=TST-DEAL-JOB1" to the end of this URL, our samplers appear and the report will now run. We are looking into how we can make bamboo do this automatically, so you don't have to paste the url each time. I will update if I find a solution.

We are using bamboo 5.5.1 build 4306.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

461 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you