Bamboo batch script fails due to 'svn' not being recognized

I have a batch script that can be ran on its own on the build pc my bamboo remote agent is installed on. However, when it is executed as part of a Bamboo plan, I get the following error.

"'svn' is not recognized as an internal or external command"

Any advice on getting Bamboo to recognize SVN.

 

I have a similar problem with other commands as well.

For instance I have this line in my batch script:
call ./Setup_RBP.bat skip        1>../Log/Setup_RBP.log

'.' is not recognized as an internal or external command, operable program or batch file.

1 answer

1 accepted

1 vote
Accepted answer

Updated away from Local System account to a specific account. Then it started to find the commands as I would expect.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

43 views 3 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you