Bamboo batch script fails due to 'svn' not being recognized

I have a batch script that can be ran on its own on the build pc my bamboo remote agent is installed on. However, when it is executed as part of a Bamboo plan, I get the following error.

"'svn' is not recognized as an internal or external command"

Any advice on getting Bamboo to recognize SVN.

 

I have a similar problem with other commands as well.

For instance I have this line in my batch script:
call ./Setup_RBP.bat skip        1>../Log/Setup_RBP.log

'.' is not recognized as an internal or external command, operable program or batch file.

1 answer

1 accepted

Updated away from Local System account to a specific account. Then it started to find the commands as I would expect.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,095 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot