Bamboo agent doesn't use correct PATH (Ubuntu)

I'm using the Ubuntu agent to try to do a Grunt build. After many days of slogging, I'm so close I can taste it.

My last problem is that the Elastic Agent is not building with a proper PATH variable, and therefore is not finding my installation of Compass and Ruby (which is part of my custom AMI Image, which was derived from the stock Bamboo Ubuntu image).

I don't know how to fix this. If I SSH in as 'ec2-user', the PATH is correct and I can build no problem. If I SSH in as 'ubuntu', again the PATH is correct. I have modified /etc/environment to have the correct PATH.

When the Elastic Agent tries to build, it can't find Compass.

How do I get it to use the correct PATH?

2 answers

1 accepted

This widget could not be displayed.

I fixed this by including a PATH= line on the build script (prior to executing my build command).

This widget could not be displayed.

You probably need to change the PATH for 'bamboo' user.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

80 views 2 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you