Bamboo Global Variables

I saw the post about Bamboo caching global variables but I'm in a situation where I have deleted the global variables and every time I run a NEW deploy it STILL uses them!

 

Can someone please tell me how I can change the global variables for when a NEW deploy is done. I'm NOT re-running anything.

 

I tried to set the variables on the Deploy environment itself but it's still grabbing the Global variables. It's pretty insane! Nothing I do gets rid of them or changes them!

 

Bamboo version is 5.15.0.1 build 51513.

1 answer

0 votes

Hi Justin,

 

I believe the behavior you are facing is because of the fact that the releases you are triggering is linked with the older build numbers which used the global variable values. Hence, the deployment releases are also using the same value because it is expected so as to maintain the consistency.

 

Try creating a new build and link a new release with this build number and see if it works or not.

 

Please accept the answer if it works for you so that others can also benefit from it.

 

Thanks,

Robhit

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

496 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you