Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Automation for Jira error 500

Alexander Krylov November 25, 2020

Hi, i install app "Automation for Jira". But when I try to use it in any project, I get an error 500. I try create new sample project and use my old project. Any idea fix it?

2020-11-25_22-07-56.png

Cause

Referer URL: https:///secure/AutomationGlobalAdminAction!default.jspa

com.google.template.soy.tofu.SoyTofuException: In 'print' tag, expression "$localeString" evaluates to undefined.
com.google.template.soy.tofu.SoyTofuException: In 'print' tag, expression "$localeString" evaluates to undefined.
	at JIRA.Automation.Project.Admin.Page.iframe(automation-admin-page.soy:53) [?:?]
	at com.google.template.soy.tofu.internal.BaseTofu.renderMainHelper(BaseTofu.java:369) [?:?]
	at com.google.template.soy.tofu.internal.BaseTofu.renderMain(BaseTofu.java:322) [?:?]

4 answers

3 votes
Chris Allport December 2, 2020

After a fresh install, we experienced this problem, too.  We uninstalled Service Desk, and A4J starting working.  Thinking that it might depend on installation order, I:

  • uninstalled A4J
  • reinstalled Service Desk
  • reinstalled A4J

The system seems to be working just fine!

Good luck!

Ferenc Nagy [Midori] March 29, 2021

Encountered the same error in Jira 8.16.0 + Service Management 4.16.0.
It helped indeed, thanks!

1 vote
Daniel Ebers
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
November 28, 2020

Hi Alexander,

no that should not be connected to issues in the Cloud.

I found an information that it is connected to Automation itself rather.
Otherwise please check if more errors from log are visible.

Meanwhile checking if other Apps interfere with Automation could help.
Probably you have one which is not coping well with Automation.

Cheers,
Daniel

Alexander Krylov December 1, 2020

Hi Daniel!

I get new virtual host and reinstall my Jira instance. Restore from backup my data. It's work now.

Thank you!

0 votes
Sam Bartolome June 26, 2023

There is a bug created for such, https://jira.atlassian.com/browse/JIRAAUTOSERVER-196

0 votes
Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
November 25, 2020

Hi @Alexander Krylov -- Welcome to the Atlassian Community!

This could be related to the incident they are currently experiencing, which you can monitor here:

https://status.atlassian.com/

Best regards,

Bill

Alexander Krylov November 25, 2020

HI @Bill Sheboy  and thank you for your response.

I have local instance Jira Server. I tried updating to the latest version Jira, but it didn't help. Now I have a version 8.14 and the same error. This app use cloud infrastructure Atlassian?

Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
June 26, 2023

Thanks for that additional information.  In this case, I recommend working with your site admin to contact Atlassian Support to learn what they suggest: https://support.atlassian.com/contact/#/

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events