Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,682
Community Members
 
Community Events
176
Community Groups

Getting No Hibernate Session bound to thread error in the log when trying to pull the AO table data

Edited

Hi All,

I am trying to pull the data from AO table and populating as Json object to send it to cloud using onStartAppMigration method which will trigger during the migration assistant. I am keep on getting the following error. When tried for the solution I found that DAO should have @Transactional annotation on the method/class being called. Even after keeping that I am still getting the error. Please suggest your advice to resolve this problem. I can share the details if needed to check. Thanks in advance.

java.lang.IllegalStateException: No Hibernate Session bound to thread, and configuration does not allow creation of non-transactional one here

===

at com.atlassian.migration.app.AbstractCloudMigrationRegistrar.lambda$startMigration$4(AbstractCloudMigrationRegistrar.java:109)
at com.atlassian.migration.app.tracker.BoundListenerImpl.onStartAppMigration(BoundListenerImpl.java:22)
at org.swift.confluence.html.service.AppMigrationServiceImpl.onStartAppMigration(AppMigrationServiceImpl.java:72)
at org.swift.confluence.html.service.ManageProfileServiceImpl.getProfilesForMigration(ManageProfileServiceImpl.java:158)
at com.sun.proxy.$Proxy4660.stream(Unknown Source)

I am using the following artifacts for the server to cloud migration

AO - 3.2.10

Spring Scanner - 2.2.0

Migration tracker - 1.22

CCMA - 3.1.8

-RK

1 answer

I ran into the same issue. Solved it by injecting TransactionTemplate and calling the database getter inside the execute method and returning the result.

Hi @Steven ,

We resolved it by adding a file src/main/resources/META-INF/spring/plugin-context.xml with following content in it.

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:atlassian-scanner="http://www.atlassian.com/schema/atlassian-scanner/2"
       xsi:schemaLocation="http://www.springframework.org/schema/beans
        http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
        http://www.atlassian.com/schema/atlassian-scanner/2
        http://www.atlassian.com/schema/atlassian-scanner/2/atlassian-scanner.xsd">
    <atlassian-scanner:scan-indexes/>
</beans>

 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events