Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,221
Community Members
 
Community Events
168
Community Groups

I need to change the epic I have linked to an issue. I have not been able to get Epic Link to work.

I'm using Jira Classic. Let me know if you need anything else.

3 answers

2 accepted

What do you mean by "Not been able to get Epic Link to work"?  Can you describe what is happening in any more detail?  I wonder if this could be a role/group permission issue, and/or might depend on the edit screen scheme being applied.  When you say you can't change the epic, I'm assuming

a) You have the ability to edit the issue in general

b) You can see the current epic your issue is linked to (ie Epic Link field)

c) You can edit the Epic Link field and enter another ticket for another epic (ie there is a pencil icon beside the field, and/or you can click on the field and edit it)

If any of these is not true, then you likely need to work with your Jira administrator to either address permissions or screen scheme being applied.

If all of these are true, then we (I at least) need you to clarify what is happening.  Screen shots might be handy, depends on the problem of course.

 

 

I see a highlighted field as seen in the screen shot.  When I select this field there isn't a drop down box, I'm merely navigated to the Epic overview page.

























 




























 
















Hi @Sherry Kinch I'm afraid I at least don't see a screen shot, so I'm flying blind a bit!  Can you go into other issues, and navigate to their respective Epics successfully? (ie Is this specific to the issue here, or is this a general problem?).  Also, if you have multiple Jira projects, do they all exhibit this behaviour, or is it just in this project?  Are other people able to be successful doing the same activities I listed above (ie is it just you or does everyone have the same kind of problem)? Finally, have you been able to do the activities above successfully in the past, and this condition has recently started, or are you new to Jira in your organization altogether, and this is the first time you're trying to change an epic link? 

Danno Rising Star Dec 16, 2020

Sherry Kinch, you'll probably need to insert the pictures in the same answer as your text. Atlassian has a bug I think where you can't insert just a picture without text.

Hi @Tom Kakanowski, I have figured out the problem. Thank you for taking the time to help me. I appreciate it very much.

 

I was trying to change a Task that had an epic already linked to it. (Those Tasks are in the backlog so I could change the epic in the backlog view. I found a Task with no Epic and the functionality worked as expected.

I hope this makes sense to you

I really appreciate the help you provided me yesterday.

Thanks,

Sherry

@Sherry KinchI don't feel like I did much for you, but I'm glad your problem is resolved!

0 votes
Answer accepted

I'm not sure what you mean by "get it to work", but you should be able to see available epics in a drop down?  Do these display or are they missing?

Have you tried looking at the issue via the Epic view on the backlog?

If you go to your backlog view, and click the EPIC view (vertical on the left), you will see all your current Epics in your project.  You can click on the currently assigned epic to filter down to just those epics, in which you should see your issue in question.  You will be able to drag your issue out of that epic and into the new epic you need to assign.

 

If you can provide a few more details, we may be able to work through the Epic Link issue, but let us know if this solves this particular problem.

IGNORE, I was unable to reply to existing response, corrected.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events