Bamboo version: 6.5
Issue: When doing a docker push task configuration I select radio button Use the agent's ~/.dockercfg credentials and successfully save the task. However, when clicking back on the task configuration, bamboo has "reset" the option to Provide username and password. Not unexpectedly, the task execution fails with no basic auth credentials
Question: Why is this happening? How can I make bamboo accept the Use the agent's ~/.dockercfg credentials option?
Alternatively: Is it possible that the push task doesn't make a logout, so credentials are kept in .docker/config.json