I notice the following errors crashing Bamboo after enabling SSO:
bamboo-0 bamboo 2018-04-18 00:45:24,368 ERROR [buildTailMessageListenerConnector-1] [BrokerService] Failed to start Apache ActiveMQ ([bamboo, null], java.lang.IllegalStateException: Shutdown in progress)
bamboo-0 bamboo 2018-04-18 00:45:24,404 ERROR [buildTailMessageListenerConnector-1] [FingerprintMatchingMessageListenerContainer] Could not refresh JMS Connection for destination 'queue://com.atlassian.bamboo.buildTailQueue' - retrying using FixedBackOff{interval=5000, currentAttempts=0, maxAttempts=unlimited}. Cause: Error while attempting to retrieve a connection from the pool; nested exception is javax.jms.JMSException: Could not create Transport. Reason: javax.jms.JMSException: Could not create Transport. Reason: java.lang.IllegalStateException: Shutdown in progress
bamboo-0 bamboo 2018-04-18 00:45:24,430 ERROR [ActiveMQ Connection Executor: vm://bamboo#0] [BrokerService] Failed to start Apache ActiveMQ ([bamboo, null], java.lang.IllegalStateException: Shutdown in progress)
bamboo-0 bamboo 2018-04-18 00:45:24,445 ERROR [ActiveMQ Connection Executor: vm://bamboo#0] [BambooServerSimpleMessageListenerContainer] Encountered non-recoverable JMSException
bamboo-0 bamboo 2018-04-18 00:45:24,461 ERROR [bambooAgentMessageListenerConnector-1] [BrokerService] Failed to start Apache ActiveMQ ([bamboo, null], java.lang.IllegalStateException: Shutdown in progress)
bamboo-0 bamboo 2018-04-18 00:45:24,475 ERROR [bambooAgentMessageListenerConnector-1] [FingerprintMatchingMessageListenerContainer] Could not refresh JMS Connection for destination 'queue://com.atlassian.bamboo.serverQueue' - retrying using FixedBackOff{interval=5000, currentAttempts=0, maxAttempts=unlimited}. Cause: Error while attempting to add new Connection to the pool; nested exception is javax.jms.JMSException: Could not create Transport. Reason: javax.jms.JMSException: Could not create Transport. Reason: java.lang.IllegalStateException: Shutdown in progress
bamboo-0 bamboo 2018-04-18 00:45:24,488 ERROR [bambooHeartBeatMessageListenerConnector-1] [BrokerService] Failed to start Apache ActiveMQ ([bamboo, null], java.lang.IllegalStateException: Shutdown in progress)
bamboo-0 bamboo 2018-04-18 00:45:24,506 ERROR [bambooHeartBeatMessageListenerConnector-1] [BambooDefaultMessageListenerContainer] Could not refresh JMS Connection for destination 'queue://com.atlassian.bamboo.heartbeatQueue' - retrying using FixedBackOff{interval=5000, currentAttempts=0, maxAttempts=unlimited}. Cause: Error while attempting to add new Connection to the pool; nested exception is javax.jms.JMSException: Could not create Transport. Reason: javax.jms.JMSException: Could not create Transport. Reason: java.lang.IllegalStateException: Shutdown in progress
Enabling SSO is done via commenting out:
<!-- <authenticator class="com.atlassian.bamboo.user.authentication.BambooAuthenticator"/> -->
And enabling:
<authenticator class="com.atlassian.crowd.integration.seraph.v25.BambooAuthenticator"/>
This is done in the atlassian-bamboo/WEB-INF/classes/seraph-config.xml fle. The complete file is here.
Bamboo version in use 6.2.2.
If I remove SSO and reinstall I don't see the errors. Any hints on what might be causing this?