crowd version is 2.9.1. crowd was accidentally started as root, so stopped crowd logging in as root, then tried to start crowd as crowdadm and it is not starting now.
Hi Dana,
Please check the logs from:
Startup errors are usually pretty self explanatory, hopefully you can find a helpful entry. If you see a message indicating a port is already in use, make sure Crowd has shut down completely before restarting.
Since you started Crowd as root, please double check that the crowdadm user still has full permissions on the Crowd Home and Crowd Install folders.
Hi Ann,
Thanks for the prompt reply. The logs are not getting updated. I have checked the permissions and owners, it is good. I changed the owner to crowdadm for files that were owned by root.
Are you starting Crowd using the start_crowd script from the Install folder? If not, please try that method and see if the logs do update. The logs start with the Tomcat log and then when the web server is up, the application (Crowd) starts and that's when the atlassian-crowd.log starts updating in the home folder.
When Crowd fails to start, is there an error in the terminal window?
Yes start_crowd.sh script is being for the starting crowd. Tomcat log or the atlassian-crowd log is getting updated. In the terminal window the message says Tomcat started.
output from the terminal window:
bash-4.1$ ./start_crowd.shUsing CATALINA_BASE: /apps/atlassian/crowd/2.9.1/apache-tomcatUsing CATALINA_HOME: /apps/atlassian/crowd/2.9.1/apache-tomcatUsing CATALINA_TMPDIR: /apps/atlassian/crowd/2.9.1/apache-tomcat/tempUsing JRE_HOME: /apps/atlassian/jira/7.5.1/Using CLASSPATH: /apps/atlassian/crowd/2.9.1/apache-tomcat/bin/bootstrap.jar:/apps/atlassian/crowd/2.9.1/apache-tomcat/bin/tomcat-juli.jarUsing CATALINA_PID: /apps/atlassian/crowd/2.9.1/apache-tomcat/work/catalina.pidExisting PID file found during start.Removing/clearing stale PID file.Tomcat started.
None of the log files are getting updated.
It looks like you're new here. Sign in or register to get started.