We had a recent issue on our GIT infrastructure due to heavy queuing up of requests. Our investigation led to the below findings.
1. We identified some of our developers using Atlassian Source Tree as GIT Client and had the default option “Check default remotes for updates every 10 minutes” enabled.
2. The queue build up was mainly due to frequent updates which did not seem to complete quickly.
We advised those developers to disable to “check default remotes” option and the situation recovered. Additionally, we have the “large files options” disabled in BitBucket to ensure there is a size control.
1. Is there a way to change the time and frequency of the “check default remotes…” option?
2. Are there any best practices around usage of Source Tree that may help avoid a similar occurrence as we deem this option to be necessary for developers?
3. What’s the limiting size of the “large files options – when disabled” beyond which the check-in function will fail?