ここでは組織内のプロキシサーバーによってクライアントへサイズ制限がかけられている場合に、サイズの大きなファイルを git lfs にてアップロードする回避策を紹介します。(1) プロキシサーバーのサイズ制限の設定例典型的には Nginx の下記設定が該当します。詳しくはドキュメント Git LFS fails with error: failed to push some refs to をご参照下さい。
client_max_body_sizeproxy_request_buffering
(2) クライアント側での回避策プロキシのサイズ制限に起因している場合は Bitbucket LFS Media Adapter を利用してファイルを分割してアップロードしてみましょう。設定方法などについて詳しくはドキュメント Troubleshoot Git LFS in Bitbucket の Error when pushing Git LFS file to Bitbucket をご参照下さい。その他、気になる点があればコメントをお待ちしております。また、当サイトでの日本語の扱いについては 日本語でコミュニティサイトを利用する をご参照下さい。
It looks like you're new here. Sign in or register to get started.