I just installed Bamboo on Windows Server 2008 R2 64 bit with Java 1.7.0_09-b05, and when running <bamboo.install.dir>\bin\start_bamboo.bat http://localhost:8085/is "unable to connect"
Here's what I'm seeing in the console output:
15:06:46,977 |-ERROR in ch.qos.logback.core.joran.action.AppenderRefAction - Cou
ld not find an appender named [stdout]. Did you define it below instead of above
in the configuration file?
15:06:46,977 |-ERROR in ch.qos.logback.core.joran.action.AppenderRefAction - See
http://logback.qos.ch/codes.html#appender_order for more details.
15:06:46,977 |-INFO in ch.qos.logback.classic.joran.action.ConfigurationAction -
End of configuration.
15:06:46,977 |-INFO in ch.qos.logback.classic.joran.JoranConfigurator@4fb97f90 -
Registering current configuration as safe fallback point
Jul 31, 2014 3:07:38 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8081"]
Jul 31, 2014 3:07:41 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Jul 31, 2014 3:07:41 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 73531 ms
Exception in thread "Distribution initialization" java.lang.NullPointerException
at java.util.concurrent.ConcurrentHashMap.hash(ConcurrentHashMap.java:33
2)
at java.util.concurrent.ConcurrentHashMap.get(ConcurrentHashMap.java:987
)
at org.xwiki.extension.repository.internal.installed.DefaultInstalledExt
ensionRepository.getInstalledExtension(DefaultInstalledExtensionRepository.java:
475)
at org.xwiki.extension.distribution.internal.job.DistributionJob.createN
ewStatus(DistributionJob.java:74)
at org.xwiki.extension.distribution.internal.job.DistributionJob.createN
ewStatus(DistributionJob.java:43)
at org.xwiki.job.AbstractJob.start(AbstractJob.java:128)
at org.xwiki.extension.distribution.internal.DefaultDistributionManager$
1.run(DefaultDistributionManager.java:165)
at java.lang.Thread.run(Thread.java:722)
Any ideas?
Thanks,
Barry